LaTeX Tips

提供: fukudat
移動: 案内検索

LaTeX を使って論文を書くための Tips集.

目次

Windows PCへのInstall方法

http://www.ms.u-tokyo.ac.jp/~abenori/tex/tex0.html にしたがってインストール.

kakuto3.exe を実行して指示に従うと,

  • W32TeX
  • dviout for Windows
  • GhostScript,GSView
  • pLaTeX2e 新ドキュメントクラス

がまとめてインストールされる.

途中 GhostScriptをインストールする時に,「Use Windows TrueType fonts for Chinese, Japanese and Korean」にチェックを入れることを忘れないこと.

文書のコンパイル

次のような Makefile を作成し,make コマンドで一発作成.

#================================================================
# Specify your tex source files here.
MAIN=main
SRCS=main.tex abstract.tex intro.tex detail.tex conclusion.tex

#================================================================
# usually, you don't have to edit the following lines.
.SUFFIXES:
.SUFFIXES:	.tex .dvi .ps .eps .aux .bbl .ind .pdf
.tex.dvi:
	$(TEX) $*
.dvi.ps:
	$(DVIPS) $*.dvi
.dvi.pdf:
	$(DVIPDF) $*.dvi
.aux.bbl:
	$(BIBTEX) $*
.aux.ind:
	$(MAKEINDEX) $*

TEX=latex
BIBTEX=bibtex
DVIPS=dvipsk
DVIPDF=dvipdfm
PREVIEW=dviout
MAKEINDEX=mendex
.PHONY:	all single double triple index clean pdf

single: $(MAIN).dvi

double: single index bibtex
	rm -f $(MAIN).dvi
	$(MAKE) single

triple: double
	rm -f $(MAIN).dvi
	$(MAKE) double

preview: $(MAIN).dvi
	$(PREVIEW) $(MAIN).dvi

ps: $(MAIN).ps

dvi: $(MAIN).dvi

pdf: $(MAIN).pdf

clean:
	rm -f $(MAIN).log $(MAIN).ilg $(MAIN).blg *~ *.pbm

distclean: clean
	rm -f $(MAIN).dvi $(MAIN).ps $(MAIN).pdf $(MAIN).idx $(MAIN).ind\
		$(MAIN).ist $(MAIN).toc $(MAIN).bbl $(MAIN).out *.aux

veryclean: distclean

list: $(SRCS) $(FIGS) $(BIBS)
	@echo $(SRCS) $(FIGS) $(BIBS)

bibtex: $(MAIN).bbl

index: $(MAIN).ind

$(MAIN).pdf: $(MAIN).dvi
	$(DVIPDF) $(MAIN)

$(MAIN).dvi $(MAIN).aux: $(SRCS) $(FIGS)
	$(TEX) $(MAIN).tex

$(MAIN).ps: $(MAIN).dvi
	@if [ -f pages ]; then\
		$(DVIPS) `cat pages` $(MAIN).dvi > $(MAIN).ps ;\
	else\
		$(DVIPS) $(MAIN).dvi > $(MAIN).ps ;\
	fi

$(MAIN).bbl: $(MAIN).aux $(BIBS)

$(MAIN).ind: $(MAIN).aux index.ist

使い方:

  • MAIN にメインの .tex ファイルの拡張子を除いた名前を,SRCSにソースファイルのリスト(.epsなどの図のファイルを含む)を列挙しておく.
  • make single (または単に make) とすると,$(MAIN).dvi が $(SRCS) より古いか存在しない場合に限り,1回 latex が走り $(MAIN).dvi が作成される.
  • make double とすると,内部で make single してから,mendex, bibtex を実行後,再度 latex を実行する.
  • make triple とすると,内部で make double してから,再度 latex を実行する.

PowerPointの絵を貼り付ける

絵を書く道具はいろいろあるけれど,プレゼンテーション(学会発表など)を考えると,PowerPointで作っておくというのは悪い選択ではなさそう.では,どうやればPowerPointの絵を論文本体に挿入することができるか.

大きな流れとしては,

  • PowerPoint で絵を描く→
  • PostScript(PS)ファイルに出力(印刷)する→
  • PSファイルをEncapsulated PostScript(EPS)ファイルに変換する→
  • LaTeXに取り込む

という手順を踏む.

逆に,PowerPoint のスライドにLaTeXの数式などを埋め込む方法は,TeXCropを参照.

  1. PostScript をファイルとして吐き出すプリンタドライバーをインストールする
    http://www.adobe.com/jp/support/downloads/pspwin.html から Windows用ユニバーサルインストーラーをゲットしても良いのだが,Win XP, Vista, 7 には MS Publisher Imagesetter (実は PostScript driver)が付属しているのでそれを使う.
    • Windows の「スタート」メニュー --> 「プリンタとFAX」 --> 「プリンタのインストール」 を選択.プリンタの追加ウィザードが開始するので,「次へ」を押す.
    • 「このコンピュータに接続されているローカルプリンタ」を選んで「次へ」.
    • 「次のポートを使用」に対して「FILE:(ファイルへ出力)」を選択しておく.これでこのプリンタに印刷するとファイルが作成されるようになる.「次へ」.
    • プリンタソフトウェアのインストール画面で,「製造元」を「Generic」にして,「MS Publisher Imagesetter」が選ぶ.「次へ」.
    • プリンタ名は,判りやすいように「Generic PostScript Printer」とでもして,「次へ」を繰り返し押して完了する.
    • 「スタート」-->「プリンタとFAX」に新しいプリンタ「Generic PostScript Printer」ができているはず.
  2. Generic PostScript Printer ドライバの設定をEPSを出力するように変更する.
    • Windows のスタートメニューから「プリンタとFAX」を選択し,先ほどインストールした Generic PostScript プリンタを右クリックしてプロパティを開く.
    • 「印刷設定...」ボタンをクリック.「詳細設定...」ボタンをクリック.
    • 「ドキュメントのオプション」の下の「PostScriptオプション」の中の「PostScript出力オプション」を「EPS(Encapsulated PostScript)」にして,すべて OK を押して閉じる.
    当然のことながら,ここまでは一回だけ実行しとけばよい.以下は,絵を描くたびに実行する.
  3. PowerPointのページを縦長に設定しておく.
    絵を書き始める前にPowerPointのメニュー「ファイル」→「ページ設定」でスライドの印刷の向きを「縦」にしておこう.そうするとあとで絵を回転しなくてすむ.(LaTeXに取り込む際に回転することもできるはずなのだが,バージョンによってはうまくいかないことがあるため)
  4. PowerPointで絵を描いたら,Generic PostScript Printer に印刷する.
    • 「ファイル」→「印刷」でプリンタを上でインストールした Generic PostScriptプリンタを選んで「OK」を押す.
    • 出力先のファイル名を聞かれたら,適当に答える.拡張子は必ず .prn となるので,あとで *.ps と名前を変えておこう.(Vista では .prn 以外の拡張子で出力することも可能みたい)
    これでポストスクリプトファイルが出来上がった.しかしこのファイルはページサイズの絵であり,周りに余白が残っている.そこで,絵の周りの余白を取り除くために以下の手順を踏む.
  5. GSViewでポストスクリプトファイルを開く.
    • *.ps ファイルをダブルクリックするか,GSView の File メニューからファイルを選択する.
  6. File -> PS to EPS を選択.ダイアログボックスには Yes と答え,保存するファイル名を入力する.
    • ファイル名には *.eps という拡張子をつけよう.
  7. 確認のため,今セーブした *.eps ファイルを GSView で開いてみる.
    • Options -> Show Bounding Box を選ぶと,どこからが余白として認識されているかが確認できる.

ここで出来上がったファイルを LaTeX の graphics (または graphicx) パッケージを用いて LaTeX ファイルに取り込めばよい.その方法は次の節で.

EPSファイルの貼り付け方

LaTeXソースのpreamble (\begin{document}の前) に

\usepackage[dvipdfm]{graphicx}

して graphicx パッケージを使うことを宣言する.オプションとして,DVI driver (dvipdfm, dvipsなど)の指定が必要.

本文中には,

\begin{figure}[!hbt]
  \centering
  \includegraphics[clip,scale=0.5]{figure.eps}
  \caption{キャプション}
  \label{fig:ラベル}
\end{figure}

などとする.ここで figure.eps は EPS ファイル.以下のオプションがある.

オプション 説明
angle 回転角度を左回りに度数で指定する。
origin 回転の原点を指定する。
width 幅を指定する。
height 高さを指定する。
scale 倍率を指定する。
bb バウンディングボックスを指定する。左下のx,y、右上のx,y座標を空白で区切って指定する。
viewport 引数を4つ指定する。原点はファイル中に指定されたバウンディングボックスに対して設定される。例えば「viewport=0 0 20 20」と指定すると画像の左下の20bpの正方形の部分が見える。
trim 引数を4つ指定する。指定した値は取り込んだ画像を切り取る左、下、右、上の空きの大きさに対応する。
clip 画像をバウンディングボックスの大きさで張り付ける。trueかfalseで指定する。
type 画像の種類を指定する。
ext 拡張子を指定する。

参考文献

個人用ツール
名前空間

変種
操作
案内
ツールボックス