Apache Derby/Installation

提供: fukudat
移動: 案内検索

Windows または Linux のユーザが Apache Derby を動作させるために必要なインストール方法を説明する.

前提ソフトウェア

Apache DerbyはJavaプログラムなので,動作させるためには最低限 Java Runtime Environment (JRE)が必要である.自分で作ったJavaプログラムから使用するためにはその プログラムをコンパイルしなければならないからJava Development Kit (JDK)が必要である.また,Javaプログラムを開発するのに統合開発環境Eclipseを使用すると便利である.

これらのソフトウェアのインストール方法は以下のページを参照してほしい.

Install

前提ソフトウェアのインストールが終わったら,以下の手順に沿って Apache Derby をインストールしよう.

  • Apache Derbyから Eclipse plug-in を入手する。
    • "Download" タブをクリック.
      Derby-1.png
    • Latest Official Release のセクションにあるリンクをクリック (2010/11/7現在 最新バージョンは 10.6.2.1)
      Derby-2.png
    • Eclipse plug-in derby_core_plugin_*.zipderby_ui_plugin_*.zip をダウンロード (2010/11/7現在 最新バージョンは derby_core_plugin_10.6.2.999685.zipderby_ui_doc_plugin_1.1.2.zip)
      Derby-3.png
  • もしEclipse が起動していたら,終了しておく.
  • 入手したファイル(derby_*_plugin_*.zip)を Eclipse のインストールされているディレクトリの下に展開する.
    • eclipseのディレクトリの下には元々 plugins というディレクトリがある.
    • そのディレクトリに,derby_*_plugin_*.zip 中にある plugins を上書きコピーする.(Windows なら explorer でドラッグ&ドロップするか copy コマンドを使う.)
    • Eclipseのインストールされているディレクトリのpluginsの下に org.apache.derby.* という名前のディレクトリがいくつかできていれば正しくインストールされている.
  • Eclipse を起動して完了.

つぎは 使い方 へ.

個人用ツール
名前空間

変種
操作
案内
ツールボックス